Issues with Engage Bridge Dialer
Incident Report for ZoomInfo
Resolved
The Engage Bride Dialer functionality fix has been implemented and restored to operational.
Posted Jun 28, 2022 - 19:10 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted Jun 28, 2022 - 18:55 EDT
Investigating
We are currently experiencing issues with the Bridge Dialer functionality within the Engage platform.

Our Engineering team is actively investigating and working to resolve as soon as possible.
Posted Jun 28, 2022 - 18:38 EDT
This incident affected: Engage.