Phone Support Temporarily Unavailable
Incident Report for ZoomInfo
Resolved
The outage at our service vendor has been resolved and access to our support team via phone is back up and functioning.
Posted Mar 05, 2021 - 11:36 EST
Investigating
Our phone service provider has indicated that they are currently experiencing a service outage. During this time, our support team may not be able to receive phone calls. If you need assistance, please email helpmenow@zoominfo.com. We will continue to post updates as we receive them from our vendor.
Posted Mar 05, 2021 - 10:04 EST