Phone Support Temporarily Unavailable
Incident Report for ZoomInfo
Resolved
This incident has been resolved.
Posted Nov 17, 2020 - 08:27 EST
Investigating
Our phone service provider has indicated that they are currently experiencing a partial service outage. During this time, our support team may not be able to receive phone calls. If you need assistance, please email helpmenow@zoominfo.com.
Posted Nov 17, 2020 - 08:16 EST