Neverbounce - Processing Issues
Resolved
The fix that was implemented has resolved the issue and jobs should now be processing as expected on the Neverbounce app and through the Neverbounce API. Additionally, any jobs uploaded during this incident should now be visible.
Posted Feb 05, 2026 - 13:01 EST
Update
We are continuing to monitor for any further issues.
Posted Feb 05, 2026 - 12:59 EST
Monitoring
Engineering has implemented a fix and bulk processing jobs should now be working as expected on both the Neverbounce app and the Neverbounce API. We will continue to monitor to ensure the issue is fully resolved.
Posted Feb 05, 2026 - 12:42 EST
Investigating
We are aware of an issue that is causing issues with bulk processing working as expected on both the Neverbounce platform and Neverbounce API. During this time, users may receive errors or may not be able to see list uploads as expected.
Posted Feb 05, 2026 - 11:48 EST
This incident affected: NeverBounce.