ZoomInfo Lite - New Sign-Up Issue
Incident Report for ZoomInfo
Resolved
Our Engineering team has released a fix, and users can now sign up for new ZoomInfo Lite Accounts.
Posted Sep 30, 2024 - 10:45 EDT
Investigating
Our Engineering team is aware of and investigating an issue when attempting to sign up for a ZoomInfo Lite account.

We will continue to share updates as we have them.
Posted Sep 29, 2024 - 12:58 EDT