Chorus Site Issues
Incident Report for ZoomInfo
Resolved
This incident has been resolved.
Posted May 10, 2022 - 12:04 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 10, 2022 - 11:56 EDT
Identified
The issue has been identified and a fix is being implemented.
Posted May 10, 2022 - 11:54 EDT
Investigating
We are investigating an issue impacting users' ability to access the www.chorus.ai page (504 error).

If you are facing issues reaching this page, please go to https://hello.chorus.ai to log in to the Chorus.

Please know our Engineering teams are working hard to resolve these issues and get everything up and running as soon as possible.
Posted May 10, 2022 - 11:52 EDT
This incident affected: Chorus.