ZoomInfo Platform Maintenance
      
    
    
      
      
        
          
            Completed
          
          
            
              The scheduled maintenance has been completed.
            
            
              Posted Mar 30, 2025 - 07:00 EDT
            
           
         
        
          
            In progress
          
          
            
              Scheduled maintenance is currently in progress. We will provide updates as necessary.
            
            
              Posted Mar 30, 2025 - 03:00 EDT
            
           
         
        
          
            Scheduled
          
          
            
              ZoomInfo will be completing platform maintenance on Sunday, March 30, 2025 between 3:00 AM to 7:00 AM ET. During this maintenance window ZoomInfo products are expected to operate as usual, however there may be intermittent disruptions. We appreciate your understanding as we perform essential upgrades to our systems
            
            
              Posted Feb 24, 2025 - 09:13 EST