Marketing - Audience Processing Delays
Resolved
All services are now operating normally, and audience processing has returned to normal operation.
Posted Jul 10, 2026 - 08:20 EDT
Monitoring
Our Engineering team has resolved the issue affecting backend processing of audiences.
The service has been restored, and audience processing has resumed. Our team will continue to monitor the service while the remaining processing backlog clears.
Posted Jul 10, 2026 - 07:18 EDT
Investigating
We are currently experiencing issues with backend processing of audiences. The team is working diligently to overcome the issue.
Posted Jul 10, 2026 - 06:20 EDT
This incident affected: Marketing.