Comparably - Website Issues
Incident Report for ZoomInfo
Resolved
This incident has been resolved.
Posted May 15, 2023 - 14:01 EDT
Monitoring
A fix has been implemented and we are monitoring the results.
Posted May 15, 2023 - 10:53 EDT
Investigating
We are aware of and currently investigating an issue that is impacting some users ability to access the comparably.com URL.

Please know our Engineering teams are working hard to resolve these issues and get everything up and running as soon as possible.
Posted May 15, 2023 - 10:23 EDT
This incident affected: Comparably.