Engagement search Latency
Resolved
The latency when filtering and searching engagements within ZoomInfo has now been resolved.
Posted Aug 25, 2025 - 11:37 EDT
Investigating
We are aware of and currently investigating an issue that is causing intermittent latency and potentially timeouts when filtering or searching for Engagements in ZoomInfo.
Our engineering team is working to resolve the issues as soon as possible, and we will continue to post updates as we have them.
Posted Aug 25, 2025 - 10:55 EDT
This incident affected: Sales.