Email Support | Third Party Vendor Outage

Incident Report for ZoomInfo

Monitoring

Our third party vendor has released a fix for the issue and is now seeing their services recover. Emails sent to our Support teams should now be delivering as expected moving forward. Previously sent emails will continue to populate retroactively. Response times may still be delayed as we work through these inquiries.

We are closely monitoring recovery on our side and will share updates as we receive them.
Posted Jun 27, 2025 - 10:02 EDT

Investigating

We are currently experiencing issues with a third party vendor that is causing delays in some emails being delivered to our Support teams. For urgent issues, please use our chat or phone options to reach our Support team.

We are actively monitoring the situation and will provide updates as we receive them.
Posted Jun 26, 2025 - 14:16 EDT