Chorus Platform UI data Processing Delay
Resolved
The issue impacting Chorus Platform Data display is now resolved. The reindexing is still in progress so there may still be some instances of delayed updates to call status and other elements while this finishes up.
Posted Sep 25, 2026 - 20:02 EDT
Monitoring
A fix has been implemented the data has started to reindex. This may take some time to fully reindex, but we are closely monitoring the results.
Posted Sep 25, 2026 - 18:15 EDT
Investigating
We are currently aware of an issue causing some delays updating call recording status and other data elements in the Chorus UI. Calls are recording, but statuses may continue to show as Live after they have ended. Our engineering team is currently investigating.
Posted Sep 25, 2026 - 17:04 EDT
This incident affected: Chorus.