ZoomInfo - Contact Search Latency
Resolved
This incident has been resolved.
Posted Mar 04, 2026 - 11:49 EST
Monitoring
Engineering has implemented a fix and contact data should now populate as expected on ZoomInfo products. We are continuing to monitor this fix to ensure the platform is operating as expected.
Posted Mar 04, 2026 - 11:40 EST
Investigating
We are aware of and investigating an issue that may cause latency or errors when accessing contact data on ZoomInfo platforms. During this time, contact data may not load as expected in multiple areas of the platform. Users will not be able to export contact data during this time as well.
Posted Mar 04, 2026 - 11:13 EST
This incident affected: Sales.