ZoomInfo Marketing | Page Loading Issues
Resolved
The page load issue for ZoomInfo Marketing has been resolved
Posted Aug 18, 2025 - 19:44 EDT
Monitoring
A fix has been implemented, and our engineering team is monitoring the results. ZoomInfo Marketing pages should all be functioning correctly at this time.
Posted Aug 18, 2025 - 19:32 EDT
Investigating
We are aware of and investigating an issue that is causing some pages on the ZoomInfo Marketing Platform not to load. These pages include: Audiences, Campaigns, and the Home Dashboard.
Our engineering team is working to resolve the issues as soon as possible, and we will continue to post updates as we have them.
Posted Aug 18, 2025 - 19:23 EDT
This incident affected: Marketing.