Multiple ZoomInfo apps, due to Cloudflare outage

Incident Report for ZoomInfo

Resolved

This incident has been resolved.
Posted Dec 05, 2025 - 04:44 EST

Monitoring

The fix released by the third party vendor is working as expected. Neverbounce, Comparably, and Ringlead are now working consistently. Our third party vendor will continue to monitor recovery efforts. During the outage, Ringlead web submissions were also not functioning as expected, and some data may be lost from this time. Web submissions should now be functioning as expected moving forward.
Posted Dec 05, 2025 - 04:35 EST
This incident affected: Sales, Comparably and Operations (Ringlead).