ZoomInfo Platform Maintenance
Completed
The scheduled maintenance has been completed.
Posted Jan 25, 2026 - 10:24 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 25, 2026 - 08:25 EST
Scheduled
ZoomInfo will be completing platform maintenance on Sunday, January 25th, between 08:00 AM and 10:00 AM ET. During this maintenance window, the NeverBounce API and application will be temporarily unavailable for a brief period. All other ZoomInfo products are expected to operate normally with minimal to no impact on your experience. We appreciate your understanding as we perform essential upgrades to our systems.
Posted Jan 25, 2026 - 08:24 EST
In progress
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 25, 2026 - 08:24 EST
Scheduled
Scheduled maintenance is currently in progress. We will provide updates as necessary.
Posted Jan 25, 2026 - 08:22 EST